[SOLVED]CPU usage high when no calculations are taking place. VPR unusable flickering TFD windows when in textured views

Fluid Dynamics for LightWave 3D
Post Reply
Posts: 14
Joined: 12 Feb 2017, 18:57

[SOLVED]CPU usage high when no calculations are taking place. VPR unusable flickering TFD windows when in textured views

Post by rednax » 19 Feb 2017, 03:18

Hi folks,

I've spent a fair amount of time building a scene in Lightwave which takes a couple of hours to sim with no issues, all is well. One container, one emitter, one collision object.
Using temperature and density in the shaders.

Now, when I move to any frame in the scene in textured or textured shaded I can see the preview just fine, as it should look, but my CPU usage jumps up to around 30% of my AMD 9590, and remains there until I switch back to untextured views. The viewport looks as expected, but something is causing the CPU in lightwave to usage so high that it's virtually impossible to manipulate the scene. Swapping to GPU changes nothing.

Note my CPU usage there on the right and the "top five" processes just under the network meter there. I'm using Windows 10 by the way.

Worse still is that VPR is utterly impossible to use. I can click VPR and CPU then jumps to 100% usage, but nothing is visible other than a hugely pixilated viewport as VPR looks on it's first pass in resolving the image. I can't even kick it in to VPR most of the time, and I'm lucky if the dropdown box actually appears, and it does so wherever my mouse is on the screen after a delay.


I also notice that both the container and emitter windows (both the control buttons and text) are flickering, as if they are being redrawn constantly many, many times per second.

I have also noted that if I click the viewport control (VPR/textured shading/wireframe etc) there is a delay between the click being recognised and the dropdown box appearing, maybe as long as 20 seconds. Sometimes the control will then appear wherever my mouse is around the screen. At that point the high CPU usage stops and the VPR begins to resolve as normal. As long as I don't attempt to change the viewport mode I can then see VPR resolving as normal, as if I have interrupted some unwanted process. Clicking on anything other than that dropdown menu ramps up the CPU again and VPR returns to a static pixelated and unprocessed view:


So, i effectively have no ability to tweek my shaders in VPR as the moment I move my mouse away from the viewport dropdown my CPU loads up to 100%.

The act of opening the dropdown view mode box seems to kick VPR (or textured shaded, textured solid) in to action while my mouse remains there, but as soon as I click out of that menu, or anywhere other than that menu it goes back to locking everything up until I click out of VPR/textued views.

This is only happening in this particular scene. All demo scenes and previously saved iterations of my scene have no problem. It really isn't a massively complex scene, although I fully expect it to take a bit of time to render.


I've gone through pretty much all of the available controls to see if toggling on/off, or zero'ing out numbers can find something, anything which may be causing the problem, but it changes nothing.

I have also saved and transferred everything to my laptop (surface book) and still get the same results. It has some flavour of 940m dGPU by the way. New scenes and sims don't suffer the same problem, so something to do with this scene, or it's complexity is causing this issue with runaway CPU load.
I've removed the plugin, reinstalled, and even uninstalled and reinstalled Lightwave itself.

I've selectively removed emitters, collision objects to no avail. As soon as I remove the container itself the problem goes away. The act of simply having the container in the scene is causing the problem.

I've a gforce GTX970 with 4gb by the way, and my display is a 4k monitor. All drivers up to date. 32gb Ram, octocore AMD.

From what I'm experiencing, my feeling is that high CPU usage is completely unrelated to the sim calculations itself. It's as if TFD is getting locked in to redrawing the container and emitter windows over and over again as a priority over anything else. It does this in textured and VPR modes only. The sim cache is already compiled so there's nothing going on in the background processes either. In task manager I see Lightwave is hogging all of the CPU.

I'm wondering if an issue similar to this has been reported before, and if there is any solution. I would hate to have to start the scene all over again, particularly if I'm hitting some limitation of TFD which I don't know of.
As far as I know, a cached sim in textured shaded mode, should not be using this amount of CPU run time when viewing a single frame in the preview window:


EDIT - I can also confirm that clicking on any of the menus in the TFD windows stops the high CPU usage, and VPR processes as normal, but the moment I select anything from that dropdown, or click in some other window, the 100% CPU usage returns and VPR stops processing.

I cant seem to find any similar reports by searching this forum! Any assistance or suggestions would be greatly appreciated!

Thank you,

Last edited by rednax on 20 Feb 2017, 13:50, edited 1 time in total.

Posts: 14
Joined: 12 Feb 2017, 18:57


Post by rednax » 20 Feb 2017, 13:45

I spent most of the weekend trying to figure out what's going on here and get back to a working state without losing my work so far, I have no idea what's causing it, but I have been able to work out a fix should anyone else experience this problem.

Create a new scene in Lightwave Layout, then File>Load >items from scene.
Find the problem scene and click OK to load it.
At this point select every item ("select all" on the right), scroll down to the bottom and UNCHECK FluidMaster and FluidShader:


The scene should now load up without any high CPU use when it should be idling. Now go to volumetric and fog and add Fluid Shader and re-load Fluid Shader:


Then go to Utilities > master plugins and re add FluidMaster:


TFD will now function properly again.
I have absolutely no idea what is going on here. Even if I open the problem scene up, remove the two plugins and re-add them, the problem is still there. Something in the plugin itself is caching, and transfering to other scenes if a direct import is done with the plugins added along for the ride.

Anyway, I hope it helps someone at some point, but having read through every forum post and googled every combination of words I could think of, it sounds like I'm the only person to have experienced this glitch.


Post Reply