0.1.4 Slow To Render

First test in R20 and render to picture viewer is a bit flaky. At first it does not render then switching off legacy bridge it renders and does so with legacy bridge switched back on.
Default settings are very slow:
I73730k @3.5 GHZ
1280x720 1x1 2x2 Cubic Still Image
Infinite light Hard Shadows on a disc as floor at 100000 outer Radius
Render Time : 6m 30 secs
With Step size at 100% render time is 1 m 44s
Note that by default scene scale is in cm and I have to go to project settings and set view clipping to huge to see the preview

R21 show nothing in the viewport and takes at least 2 attempts to render a frame. First renders are blank and of 240 frames it caches up to frame 220 at 95,647 kb then a 0 kb frame 221 and then a 489,049 kb frame 240. But clearing the cache and resimming sorts that out so it is hit and miss.reactionsr21.zip (20.3 KB)

R23 has really bad viewport issues…R20 is the only version that seems OK with viewport

R21 gave frame 220 at 95647 kb and R23 gives 97286 but at last R23 did the whole sim at the first attempt.

Now R20 is bailing out mid way through the sim reactionsr20.zip (97.6 KB)

Issues with sequence render to Pic.Viewer
Confirmed, looking into it.

Slow render times
I couldn’t reproduce the render time regression. Could you attach a scene that renders slower in 0.1.4 than 0.1.3?

Viewport issues
I couldn’t reproduce these, yet. Does this also occur when simulating on GPU 0?

Incomplete simulations
I couldn’t reproduce these, yet. Are these simulations that you ran in the viewport or as part of a sequence render to Picture Viewer?

I think the render times were the same with 1.3 and 1.4 I had simply pushed the step size up to 100 % for all testing. I have had my suspicions about the Titan for some time now and will do some tests later today with just the 1070, the Titan and both. The incomplete simulations occur when running the timeline to create the cache as is standard procedure I assume. The thing is it IS C4D version dependant , either that or running a sim which does not complete on earlier builds and then deleting the cache somehow leaves some files that R23 uses to make a complete sim with no missing frames. So I will make sure ALL folders are emptied inbetween sims. What are these odd temp files that are created in the cache folder that are not rea files ? As an aside Reactions stand-alone seems fine and I can cache well with that and convert to vdb and use that for testing- I am mainly testing render variations with RS and Arnold AR and Physical. I have not yet worked out how to do a rea sim and then open C4D and load those files up into an empty scene.

Temp files in cache
All cache files are stored to a temporary name first before getting moved to their final name. This ensures that failure to write a cache file does not leave an incomplete or broken file in the frame sequence.
If a temporary file is not renamed to the final name in the frame sequence, the renaming failed for some reason that will then show up in the log. This might happen for example if the file was concurrently used by a render job.

Loading a cache with a different scene
The File Import node will allow loading data from any cache. As of 0.1.4 there are known issues that prevent that from working properly, though.

1 Like

Yes I tried the FIN and as you say it seemed to do nothing apart from add itself to object manager.

OK tried using the 1070 on R20 and no joy, bails out again reactionsR20.zip (9.8 KB)

R21 is the same, bails out but does not even show the viewport preview,
reactionsr21.zip (15.1 KB)

And R23 has done the whole sim !! and If i leave the viewport alone it shows the previews. of course when i zoom out at the end it clips. As an aside there does not seem to be an ability to pan upwards in the SO Reactions program, just rotate and zoom in and out… reactionsr23.zip (20.6 KB)

Clearly the priority is to get it working and stable on R23 and it seems OK for now…i will do some more test runs on the 1070 then try the Titan. If it is stable on R23 I am a happy bunny though I do prefer to work in R21 and that is generally a solid stable build.

OK 3 runs on the 1070 and 2 on the Titan and R23 seems OK.FYI here are the file sizes and log. reactionsr23.zip (90.9 KB)

Thanks for the feedback.
I’ll see if i can reproduce the sim issues in R20/21. The logs unfortuantely don’t reveal any issues.

You can pan/zoom/rotate in the standalone by left-dragging while holding the 1, 2 and 3 keys respectively like in C4D.

Ah it was the 1 pan i was missing…I very very rarely use the keyboard in C4D

The standalone will get more buttons and toolbars eventually. Until then i have added a list of shortcuts to the Use Guide:

1 Like