Beta Release v0.2.8

Download Windows Installer
Getting Started
User Guide

System Requirements

  • Windows 8.1 or later
  • GPU simulation requires an Nvidia GPU with CUDA CC 3.5 or later (see CUDA GPUs | NVIDIA Developer).
  • (optional) Cinema 4D R20 or later
  • (optional) Redshift v3.0.53 or newer.

Changes

  • [C4D] Added support for R26.
  • [C4D] Added Preferences/Reactions page.
  • [C4D] Mapped disabled-state to Attribute Manager UI elements.
  • [C4D] Don’t create TFD Legacy Render Bridge by default. Added menu item instead.
  • [C4D] Fixed: particle instancer did not create empty cache correctly.
  • [C4D] Fixed issue with Undo Bridging.
  • [C4D] Fixed crash caused by conflict with Redshift.
  • [Preferences] Added ‘Viewport Render on GPU’ option for when using CPU compute.
  • [Rake] Ported all remaining CUDA code to Rake.
  • [Rake] Support template aliases.
  • [Rake] Support constant if-expressions.
  • [SDK] Added standalone ApiExample.
  • [SDK] Added VolumeGridI::sample.
  • [SDK] Fixed issue during initialization when used in standalone mode (e.g. 3rd party render job).
  • [Templates] Added Clean Flames template.
  • [UI] Fixed: Save File dialogs did not append file extension by default.
  • [Undo] Parameter changes did not force graph update in some cases.
  • [UserGuide] Added Volume Material page.
  • [Viewport] Fixed broken viewport render on some systems.
  • [Volume] Added Loop Animation in Volume Grid/Loop.
  • [Volume] Several small performance improvements.
  • [Volume] Completed CPU compute support for all simulation nodes.
  • [VolumeMaterial] Added Density/Use Emission Remap option.

Quick look at the new Loop Animation feature and CPU simulation in C4D R26:

1 Like

How do I get my C4D license in 25/26 to register it for reaction? No matter what I do it wont activate. It’s activated on R21 but I don’t use that anymore and Things have changed since Maxon One.

I’m having issues installing 0.2.8. I get the following error:
NVIDIA_Share_2022-05-04_22-09-30
It won’t let me uninstall 0.2.7 either. I get the same error.

I did copy reaction plugin to R26 when it was released. I’ve tried removing it and then installing/uninstalling but it doesn’t work.

Reactions should ask you for your login on startup unless it’s already activated. The login is independent of your C4D license.
Does it not activate when you enter the login or does neither the login window nor the plugin appear in C4D?

This problem is most likely caused by a bug in an earlier installer that did not clean up properly. Please try the Microsoft tool linked below to clean up the installation. Then try installing again.

Can this version work without the need for an NVidia driver? I want to test the standalone version only through a CPU. When I start it, an NVidia driver message appears. Thanks in advance!

I’m using a Radeon GPU.

Not yet. The Nvidia driver will be fully optional in one of the next updates.

1 Like