Channel Settings Greyed out in C4D R23 (Student)

Hi there,

I recently purchased a copy of Turbulence FD and am unable to assign the channels in Redshift so I can shade it. I’ve attached a screenshot.

I’m using C4D R23.110 (student), and the student license of Turbulence FD (latest version).

Thank you!

There is an issue in current Redshift versions that prevents it from finding TFD v1.0 1474 or newer. The Redshift team is working on a fix.

If you need to render using Redshift now, you can revert to TFD v1.0 1472 which you can find in the Build Archive. For Redshift to find TFD v1.0 1472 or older, it must be installed into the C4D plugins folder:
(Windows) C:\Program Files\Maxon Cinema 4D R2x\plugins
(MacOS) /Applications/Maxon Cinema 4D R2x/plugins
If this folder does not exist, you can simply create an empty folder with that name.

Also, the TFD folder must not be nested inside another one. That is, after extracting TFD, the .xdl64 (Windows) or .xlib (MacOS) files must be at
(Windows) C:\Program Files\Maxon Cinema 4D R2x\plugins\TurbulenceFD_C4D_v1-0_1465\TurbulenceFD_R2x_1465.xdl64
(MacOS) /Applications/Maxon Cinema 4D R2x/plugins/TurbulenceFD_C4D_v1-0_1465/TurbulenceFD_R2x_1465.xlib


That solved the issue, thank you for the reply!

It looks like v1472 doesn’t have an xdl64 for R24. Before I realized the mistake, I had already installed the one for R23 and the simulation wouldn’t run. Is there a solution for R24 & Redshift, or will we just have to wait for an update from Redshift?

There is a workaround to help RS 3.0.50 and older find the TFD plugin:

  • Install TFD for both C4D R24 and R21. If you don’t have C4D R21 installed, just specify any folder to the TFD installer in the R21 row.
  • Copy the file TurbulenceFD_R21_1476.xdl64 from the C4D R21/plugins/TurbulenceFD folder to the C4D R24/plugins/TurbulenceFD folder
  • Rename the C4D R24/plugins/TurbulenceFD folder to TurbulenceFD_C4D_v1-0_1476
  • Restart C4D

This process also works for R23.


Yes! That worked perfectly.