Container not loading cache

Hi there,

I am using Cinema4D R18 for Mac. I produced an animation using TFD and I am using a render farm to render it. I have to change the directory of the cache, since the render farm I am using only have Windows and my animation was done using a Mac. The issue is, everytime I change the directory of the cache with another path directing to another folder where I copy/pasted the cache, the containers in cinema4d don’t load… Even in my machine. Is there a way to do this?

I hope someone is able to help, I thought this was a simple task, but it’s now taking me a full day and haven’t even solved the issue (desperation)

Use relative paths, best to Save project with assets and all the tfd cache will be saved with the project. then pass all that on to a render farm.

1 Like

From Pixel Plow…“Use of Turbulence FD in your scene file requires that you use relative pathing to point to your simulation container. This is only functional in TFD builds 1.0.1047 and later. The relative path must be to the folder that holds the folder of your simulation cache, contrary to what would make sense. This means, if your simulation cache is in a folder called “Cache 001”, and that folder is sitting in the same folder as your scene file, the relative path to your cache would simply be “./”…meaning the folder holding your scene file. Apparently, that’s where Turbulence FD looks to find the folder that holds your simulation cache files. After defining a correct relative path to the cache files, you must select the cache again to link it to the object you wish it to modify.”
Also check for TFD version mismatches on the farm and locally
and see here Deadline Render?

1 Like


Thank you for such detailed answer! Plus suggestions, which I totally agree with. Will try the relative path X

1 Like

Hello, I just want to say that all your suggestions worked and I managed to use the farm to render the C4D scene. The issues were, as you very wisely pointed out: the relative path + plugin version.

Just in case other people are having similar issues with plugin, I am working on a MAC and the farm is windows based. My plugin version is 1.0.1459 (MAC) and I had to use the windows version 1.0.1372 in the farm. It skipped some frames but it wasn’t a big deal at all.


1 Like

So I will throw in a shameless plug for my tutorial set !!
My 13+ Hour Tutorial Set…Even I Reference It When I Forget !!