Getting Stepping / Boxy Renders

I sole heartily apologize for the long message, but I can’t seem to figure this out.

I’ve been trying to fix this problem in many different ways. Either by lowering the step size to 5%, to changing the color and placement of knots in the emission, to lowering the voxel size, but no matter how much I try I can’t seem to get this boxy looking render out. I even mimicked a simulation I did in Explosia FX to Turbulence FD, and the look is always the same, a boxy looking render, looking like steps or something, it’s driving me nuts, been going at this for 2 straight days.

From trial and error, the stepping seems to be coming from the scatter/absorption channel. I don’t know if this is a redshift problem with Turbulence FD, or vice versa.

The steps seem to appear when the values or high, like high temperature/density. When I did a sim on Explosia all I had to change was the voxel size for resolution, this stepping stuff wasn’t even a thing. I even tried using a VDB from Redshift, and I’m getting the same boxy looking render.

I used X particles for the particles, I’m getting stepping, I used a basic sphere with high segments as the source, still getting steps.

Today I came across this fourm where one had the same problem, and someone said:

“In order to check what exactly the source of the sharp edge is, try using default shading settings, especially for the mapping curve and thickness values. Then find the value range of your input channel by selecting the shader in Container/Viewport Preview/Shader and clicking the Container/Viewport Preview/Fit Range button.”

So I went to the viewport preview, pressed Fit Display Range and it came to a value of 217.992.

Does anyone know what I should do with this value in Redshift, or anyplace else, what does this mean exactly?

Thank you for reading, it took me a few days to just figure out why Redshift wasn’t reading TFD, and now this…I’m gonna take a break.

Any help will be greatly appreciated.

P.S. - Lowering the step-size does not work.

Best,

Kenny

Screenshot (48)|690x375

One technique is to add a RS object tag to the TFD container and then lower the step size there try halving it
My Tutorials

@Jascha_Wetzel I quoted one of your responses about the stepping I seem to be having trouble with, it was from a previous post of you explaining why it occurs, and how to fix it. You said:

In order to check what exactly the source of the sharp edge is, try using default shading settings, especially for the mapping curve and thickness values. Then find the value range of your input channel by selecting the shader in Container/Viewport Preview/Shader and clicking the Container/Viewport Preview/Fit Range button.

I understood the part about the Fit Range Button, on the viewport the steps looks smoother, but in Redshift it’s still the same. When I get that input range, where do I put it in Redshift? I’m someone who’s still learning C4D, RS, and now TFD, so I’m not entirely sure where things go, or where to put certain values.

If you can please just walk me through this that’ll be fantastic. Once I figure this out I plan on doing a tutorial so if others come across this they can watch how to fix this.

Thank you.

  • Kenny

You can also try to change the remap density settings in the advanced shader tab. Try lowering the new max

Thank you for your reply, but this doesn’t fix the problem, unfortunately. By lowering the New Max I make the emission lighter, if I then lower the emission I see the stepping again due to the smoke. I’ve tried every scenario, even bringing the voxel size down to .5, and I still get extreme stepping, as if this is what TFD is, and I know its not.

I even tried applying an object tag, for small scale simulations, it works by lowering the smaple step from 1 ot .5, but for large scale explosions, all it does and make the steps smaller, and the problem still persists. I’ve seen simulations with TFD via Redshift before, so I know its possible, so its something I’m doing wrong, but I don’t know what it is.

As I said twice before, I need to know what @Jascha_Wetzel meant when he was explaining what to do with the Fit Range Button value, and how to incorporate that with Redshift. I’ll just wait for his reply.

Put an example file up with the problem

In your viewport preview settings click on fit display range for each channel. Copy those numbers into your old min and max settings in redshift then play with the new min and max settings

  • There’s the link to the files. Explosion Test 4 is the Big scale explosions that uses X-Particles. The 2nd file is just a sphere with a big explosion.

can you do a similar file with standard particles or TP that also recreates the problem as I do not have XP. You can rar/zip them and upload to the forum

I am in the middle of a render so will have to look later

Yeah, just open the 2nd files which is the explosion with just the sphere. And please no rush, thank you for taking the time.

With the advanced settings, I see Old Min | Old Max | New Min | New Max, when I press Fit Display Range I get Range Start: 0 and Range End 387.244. So where do I input those values in the Density Remap Range in the Advanced Tab?

Old Min 0
Old Max 387.244

Holy crap its think it’s working. Wow…what a learning curve. I’m going to play around with what I’ve learned, but I think I got this figured out. By inputting the Range Values in the Advanced Tab, the stepping decreased, but I still needed to add a Redshift Object Tag, and set the Volume from 1 to .5, and then everything was smooth. So it takes the object tag set to .5 in the volume setting, and inputting the correct range values in the advanced tab. I’m going to play around with this and see its limitations, butrendering TFD straight out into Redshift seems to work for me now.

But here’s something else: Lets say I want to render this sequence as a VDB, for these VDB’s do I have to input the values all the time? I’ve gotten free VDB’s from other creators where they used Turbulence FD and I didn’t have to input values into Redshift. The last photo is of a vdb straight out of TFD and into the Redshift Volume Object, and you see the stepping, its embedded into the vdb file.

When I rendered VDB’s from Explosia, there was no stepping in the VDB’s, and just like this one, the voxel size was set to 1.5.

If you could @Paul_Selhi , could you render me a quick VDB file [whenever you can], just one frame, a lot of curls, voxel size down like 1.5, and share it with me? I’ll then place it into my volume object and if there’s no steeping on your end on the vdb file, but on my end…then there’s something in my settings.

When you export VDBs from TFD, the grid values are stored as simulated and can thus be larger than one. Creating grids with values larger than one can be useful at times, but, as you have found out the hard way, also adds another pitfall. Thus, when working with VDBs you better always keep an eye on the value ranges, since you can create VDBs with values larger than one in most simulation tools.

If you create the VDBs yourself, another option is to adjust the simulation to not create values larger than one in the first place.
If all your emitter tags use Emission Mode “Set” and a Value of 1.0 or less, they won’t create values larger than 1.0.
Special consideration needs to be given to Fuel combustion, though. It acts similar to an emitter in “Add” emission mode and can thus create values larger than one. It can create Burn, Temperature and Density depending on your settings.
The simplest way to control the channel values is to check their range using the Fit Range Button and adjust the combustion parameters as follows if necessary. Since burning fuel creates Temp./Dens./Burn and you have too much of it, you can either create less or remove more. In order to create less, lower the Simulation/Fuel/Burn Rate and/or Temp./Dens. Emission parameters. In order to remove more, increase the Simulation/Temp/Cooling, Simulation/Density/Dissipation or Simulation/Burn/Decay parameters respectively.

1 Like

All the settings you used in RS to get rid of blockiness are confined to that scene file in the RS settings, these have nothing to do with altering the vdb file…that is just read.

@Jascha_Wetzel & @Paul_Selhi , I thank you so much for your time and patience with me. Below is a summary of my personal findings and experience, for anyone new who may come across this topic:

From the photos attached to this reply, you can see I’ve taken what was explained to me in great detail, and notice that there is no stepping in these photos, and this is without adding a Redshift Object Tag, and without remapping the values using the Old Min & Max settings, this is straight out of the box from TFD, with a constant Density Value set to 1. [The only alteration I did for the 2nd photo was adjust the New Max Settings to make the Density appear thicker]

Keeping your eyes on the value is key, this was something I had to learn the hard way. I also learned that no matter how much detail you implement in these renders, there will always be some sort of stepping involved, even highly detailed ones, but you hardly notice it unless you’re looking for them. The true magic, is lessening the affect when needed. There are 2 scenarios:

  1. For tight close up shots like flying through clouds for example, require you [or at least me] to have less stepping as possible. This can be achieved from what @Jascha_Wetzel said in his response before this one. What I personal do for quick turnaround, is just set the the Emitter Density Value to 1, leave fuel unckecked. Or if Fuel is checked, set Density to 0 in the Simulations Tab, or 0.5 (play with this value).

  2. For explosions, having a Density value between 1-5 is ok, your smoke will be thick enough and there really is no reason for you to go past those values from my experience. There will be stepping [minimal], but from a wide shot, instead of up super close up, you won’t see it, and I imagine by adding motion blur, you would hardly notice it. If you do go past the value of 5, the stepping will look like something out of MineCraft. Earlier I had Fuel Density set to 20, which added up to a value of 217 because every second adds more Density, so the stepping was excessive, you can see it in a photo I posted in an earlier post.

Redshift with Volumes does have major flaws though. If you’re rendering straight from TFD, you can add a Redshift Object Tag to the TFD container, go to Volume and lower the Sample Step to smooth out the Stepping. However, if you were to add a Redshift Object Tag to a Volume Container for your VDB, the Sample Step option is gone, and there is no way for you to smooth out the steps. You could increase the Old Max values under the Advanced Tab of your Volume Material, but that gets rid of the detail of your density/smoke. Another gripe is that when rendering TFD from RS, you can’t render Emission by itself, something has to be in the Scatter channel, from there you can just lower the scatter and absorption values to only get emission/fire, it’s weird.

I plan on rendering an explosion from all angles using TFD and RS, and posting it back here as reference from what I’ve learned.

Thank you for reading. I hope someone finds this useful.

Best,

Kenny

1 Like