How to fix those artefacts

Hi everyone!

I was hoping that someone could help out with these artefacts, I had a look into the Jawset documentation but I can’t find the solver parameter that will tackle that. I tried to crank the voxel size down to 0.5 but all I get is a slow simulation.

Would be awesome if someone could point to the right parameter of give an example of a fine setup.

Here’s mine at the moment.

Thank you!

lower the render step sizes

1 Like

Stepping artefacts come from sharp changes in rendered voxel color or opacity. That is, the values that the renderer uses after the input channel values have been re-mapped by the curve and color gradient from the shader settings. This means it can either happen when you have a sharp increase in a mapping curve and/or if many/most input values are mapped by the curve to very similar intensities. The latter case often happens if you have large input values (>1.0).

In order to check what exactly the source of the sharp edge is, try using default shading settings, especially for the mapping curve and thickness values. Then find the value range of your input channel by selecting the shader in Container/Viewport Preview/Shader and clicking the Container/Viewport Preview/Fit Range button. Note the maximum channel value it shows. Your remapping curve should cover the entire range of values that are present in the input channel.
If you are using TFD’s builtin shaders, another way of keeping an eye on the input value range is to activate the histogram in the mapping curve editor. It will overlay you curve with the histogram of input values, such that you see in which range most of your values are.

With this approach you should be able to easily smooth out your cloud. If you want the visual contours back, carefully modify the shading settings to the point where the balance between contour sharpness and stepping artefacts works for you.

1 Like