Lightwave 2019 and 2020 crashing when I hit Edit Mapping, and general issues

Edit: This is on macOS Monterey (and Big Sur, co-worker’s). Everything works fine on the PC build of LW and Turbulence as far as I can tell.

Upgraded my OS because High Sierra was finally too old, and so I had to upgrade my Lightwave. Well I tried out some Turbulence and lo and behold builds 1416 and 1443 (the older and the latest) don’t work in Lightwave 2019 or LW 2020. It works in Lightwave 2015 though. Sadly Lightwave 2015 menus are all broken when you upgrade your Mac OS past High Sierra.

The issue: If you just calculate simple temperature and render it with the smoke shader, it’s black. If you map it temp to fire, it renders fire, but if you map temp to smoke it’s black. If you turn off illumination, it renders white smoke, but not with illumination.

If you click the Edit Mapping under the smoke shader tab, it instant crashes 100% of the time. It does it for me, it does it for a co-worker in Houston. It does it in LW 2019.0.3 and LW 2020.0.2. It does work in LW 2015 though, but like I said, 2015 no longer works in any OS past High Sierra.

I know lightwave is basically dead but I’m still supporting clients and animations so if it’s possible to have turbulence working that would be awesome.

Has anyone run into this issue at all? Is anyone successfully using turbulence in LW 2020? I’m going to do more digging, but my initial searches didn’t turn up anything. Thank you for any advice.


I’m not sure if this is helpful. Here is the Mac Crash report:

Translated Report (Full Report Below)

Process: Layout [23599]
Path: /Applications/NewTek/*/
Identifier: com.newtek.LightWave.Layout
Version: 2020.0.2 (2020.0.2)
Code Type: X86-64 (Native)
Parent Process: launchd [1]
User ID: 503

Date/Time: 2022-07-28 19:27:50.2420 -0400
OS Version: macOS 12.5 (21G72)
Report Version: 12
Anonymous UUID: 00907B87-81DE-D7D5-2E64-271634D2FC48

Time Awake Since Boot: 280000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information:
abort() called

Thread 0 Crashed:: Dispatch queue:
0 libsystem_kernel.dylib 0x7ff81707100e __pthread_kill + 10
1 libsystem_pthread.dylib 0x7ff8170a71ff pthread_kill + 263
2 libsystem_c.dylib 0x7ff816ff2d24 abort + 123
3 libwx_baseu- 0x137100959 wxAbort() + 9
4 libwx_baseu- 0x137210f44 wxEvtHandler::SafelyProcessEvent(wxEvent&) + 212
5 libwx_osx_cocoau_core- 0x1388e2a8b wxWindow::MacDoRedraw(long) + 795
6 libwx_osx_cocoau_core- 0x1389ad787 wxWidgetCocoaImpl::drawRect(void*, NSView*, void*) + 791
7 libwx_osx_cocoau_core- 0x1389ac326 wxOSX_drawRect(NSView*, objc_selector*, CGRect) + 86
8 AppKit 0x7ff81a1908f3 -[_NSOpenGLViewBackingLayer display] + 824
9 QuartzCore 0x7ff81e6a9a07 CA::Layer::display_if_needed(CA::Transaction*) + 873
10 QuartzCore 0x7ff81e8012aa CA::Context::commit_transaction(CA::Transaction*, double, double*) + 640
11 QuartzCore 0x7ff81e68ae6d CA::Transaction::commit() + 777
12 AppKit 0x7ff819c481d1 __62+[CATransaction(NSCATransaction) NS_setFlushesWithDisplayLink]_block_invoke + 285
13 AppKit 0x7ff81a38ff5c ___NSRunLoopObserverCreateWithHandler_block_invoke + 41
15 CoreFoundation 0x7ff81716c5ba __CFRunLoopDoObservers + 543
16 CoreFoundation 0x7ff81716ba3c __CFRunLoopRun + 840
17 CoreFoundation 0x7ff81716b034 CFRunLoopRunSpecific + 562
18 HIToolbox 0x7ff8202875e6 RunCurrentEventLoopInMode + 292
19 HIToolbox 0x7ff820287213 ReceiveNextEventCommon + 283
20 HIToolbox 0x7ff8202870e5 _BlockUntilNextEventMatchingListInModeWithFilter + 70
21 AppKit 0x7ff819adbfad _DPSNextEvent + 927
22 AppKit 0x7ff819ada66a -[NSApplication(NSEvent) _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 1394
23 libtools.2020.0.2.dylib 0x108ded481 0x108c4b000 + 1713281
24 libtools.2020.0.2.dylib 0x108dd273c WManGetInput + 252
25 Layout 0x107fcfd15 0x107e80000 + 1375509
26 Layout 0x108097c6d 0x107e80000 + 2194541
27 dyld 0x10f8e952e start + 462

Thread 1:
0 libsystem_kernel.dylib 0x7ff81706a97a mach_msg_trap + 10
1 libsystem_kernel.dylib 0x7ff81706ace8 mach_msg + 56
2 CoreFoundation 0x7ff81716d560 __CFRunLoopServiceMachPort + 319
3 CoreFoundation 0x7ff81716bbf0 __CFRunLoopRun + 1276
4 CoreFoundation 0x7ff81716b034 CFRunLoopRunSpecific + 562
5 CoreFoundation 0x7ff8171f2567 CFRunLoopRun + 40
6 Sentinel 0x10858ef11 SUP110BIA + 620
7 libsystem_pthread.dylib 0x7ff8170a74e1 _pthread_start + 125
8 libsystem_pthread.dylib 0x7ff8170a2f6b thread_start + 15

Thread 2:
0 libsystem_pthread.dylib 0x7ff8170a2f48 start_wqthread + 0

Thread 3::
0 libsystem_kernel.dylib 0x7ff81706a97a mach_msg_trap + 10
1 libsystem_kernel.dylib 0x7ff81706ace8 mach_msg + 56
2 CoreFoundation 0x7ff81716d560 __CFRunLoopServiceMachPort + 319
3 CoreFoundation 0x7ff81716bbf0 __CFRunLoopRun + 1276
4 CoreFoundation 0x7ff81716b034 CFRunLoopRunSpecific + 562
5 AppKit 0x7ff819c499ce _NSEventThread + 132
6 libsystem_pthread.dylib 0x7ff8170a74e1 _pthread_start + 125
7 libsystem_pthread.dylib 0x7ff8170a2f6b thread_start + 15

Lots of thread stuff… not sure it’s helpful… skipping ahead…

Thread 91:
0 libsystem_pthread.dylib 0x7ff8170a2f48 start_wqthread + 0

Thread 0 crashed with X86 Thread State (64-bit):
rax: 0x0000000000000000 rbx: 0x000000010f964600 rcx: 0x00007ff7b807bca8 rdx: 0x0000000000000000
rdi: 0x0000000000000103 rsi: 0x0000000000000006 rbp: 0x00007ff7b807bcd0 rsp: 0x00007ff7b807bca8
r8: 0x00000000000006e0 r9: 0x0000000000000050 r10: 0x0000000000000000 r11: 0x0000000000000246
r12: 0x0000000000000103 r13: 0x00000001372998a8 r14: 0x0000000000000006 r15: 0x0000000000000016
rip: 0x00007ff81707100e rfl: 0x0000000000000246 cr2: 0x000000013725f59c

Logical CPU: 0
Error Code: 0x02000148
Trap Number: 133

Binary Images:
0x7ff817069000 - 0x7ff8170a0fff libsystem_kernel.dylib () /usr/lib/system/libsystem_kernel.dylib
0x7ff8170a1000 - 0x7ff8170acfff libsystem_pthread.dylib (
) /usr/lib/system/libsystem_pthread.dylib
0x7ff816f71000 - 0x7ff816ff9fff libsystem_c.dylib () /usr/lib/system/libsystem_c.dylib
0x1370f5000 - 0x137293fff libwx_baseu- (
) /Applications/LightWave3D PLUGINS current//TurbulenceFD_1416.plugin/libwx_baseu-
0x1388bd000 - 0x138ca7fff libwx_osx_cocoau_core- (
) <11f250b2-5667-3688-8e93-98835890fa13> /Applications/LightWave3D PLUGINS current//TurbulenceFD_1416.plugin/libwx_osx_cocoau_core-
0x7ff819a9d000 - 0x7ff81a92cfff (6.9) /System/Library/Frameworks/AppKit.framework/Versions/C/AppKit
0x7ff81e688000 - 0x7ff81e99afff (1.11) /System/Library/Frameworks/QuartzCore.framework/Versions/A/QuartzCore
0x7ff8170ee000 - 0x7ff8175eefff (6.9) <32d2d187-4e52-376e-bc07-245a48c37e2b> /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
0x7ff820259000 - 0x7ff82054cfff (2.1.1) <95eab511-8fc1-353a-ac8a-26aa19032e2e> /System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox
0x108c4b000 - 0x1091f0fff libtools.2020.0.2.dylib (
) <3ff2a00a-d0fd-3281-9496-9cc759a3a7fa> /Applications/NewTek//libtools.2020.0.2.dylib
0x107e80000 - 0x10830cfff com.newtek.LightWave.Layout (2020.0.2) <5c7e4e39-8204-3c99-a1be-b8af3990b441> /Applications/NewTek/
0x10f8e4000 - 0x10f94ffff dyld () /usr/lib/dyld
0x10858d000 - 0x108590fff Sentinel (Sentinel version 7.1.2) <39a02059-349e-9cdc-7805-47ed1c96b8ea> /Applications/NewTek/
0x10bd8e000 - 0x10c2bcfff org.qt-project.QtCore (5.12) <7b4f0d75-dad1-30fd-ba6a-ff45ca16043b> /Applications/NewTek//QtCore.framework/Versions/5/QtCore
0x109b07000 - 0x109c3cfff libcore.2020.0.2.dylib (
) <7b82275b-f2f8-3600-9d6d-d6a6f48918e5> /Applications/NewTek//libcore.2020.0.2.dylib
0x108606000 - 0x108624fff libtbb.1.0.0.dylib (
) <4c8f6462-e14b-39bb-8448-5a31f1cc5a90> /Applications/NewTek//libtbb.1.0.0.dylib
0x137b1c000 - 0x137fccfff com.jawset.Turbulence (
) /Applications/LightWave3D PLUGINS current/*/TurbulenceFD_1416.plugin/Contents/MacOS/TurbulenceFD

External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 0
thread_create: 0
thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=1.1G resident=0K(0%) swapped_out_or_unallocated=1.1G(100%)
Writable regions: Total=1.3G written=0K(0%) resident=0K(0%) swapped_out=0K(0%) unallocated=1.3G(100%)

                            VIRTUAL   REGION 

REGION TYPE SIZE COUNT (non-coalesced)
=========== ======= =======
Accelerate framework 512K 4
Activity Tracing 256K 1
CG backing stores 1920K 8
CG image 144K 18
ColorSync 228K 27
CoreAnimation 94.2M 72
CoreGraphics 16K 3
CoreImage 20K 2
CoreUI image data 528K 10
Foundation 32K 2
Kernel Alloc Once 8K 1
MALLOC 536.8M 207
MALLOC guard page 32K 8
MALLOC_LARGE (reserved) 80.1M 3 reserved VM address space (unallocated)
MALLOC_NANO (reserved) 384.0M 1 reserved VM address space (unallocated)
OpenGL GLSL 256K 3
Stack 145.2M 92
__CTF 756 1
__DATA 93.2M 533
__DATA_CONST 23.5M 251
__DATA_DIRTY 1030K 148
__LINKEDIT 658.5M 90
__NV_CUDA 8736K 1
__OBJC_RO 82.8M 1
__OBJC_RW 3200K 2
__TEXT 505.1M 511
__UNICODE 592K 1
dyld private memory 1024K 1
mapped file 515.7M 74
shared memory 1328K 22
=========== ======= =======
TOTAL 3.1G 2258
TOTAL, minus reserved VM space 2.7G 2258

I’m still using the PC version, so not sure if this helps, but I’m successfully using Tfd on LW 2020, but there are a few problems with it.

The smoke colour gradient doesn’t work at all, this has to be disabled, and just use the colour swatch instead. Also, smoke thickness needs to be bumped up to even see any smoke.
On PC though, it doesn’t crash when I go to Edit the Smoke Mappings though, but have you tried removing the smoke colour gradient, to see if this helps a little?

No, I’m not sure how you disable the smoke color gradient. Usually I go to Render > Smoke Shader > Mapping and apply temperature to the Smoke Channel. Then I hit Edit Mapping and clip off just the edge the simulation on the nearly 0° temp. So 1 to 1 and 0 to 0.001. That makes it render SO much faster. But that’s when it all worked, not it won’t render any smoke with temperature mapped to the smoke shader. It’s just a bug, probably with newer Mac OS. On the PC it works pretty normal from what I’ve tested.

Now for the color gradient, I don’t usually deviate the color. But I assume you mean in Render > Smoke Shader > Color & Opacity - Smoke Color and checking off the [T]?

I tried unchecking it and the smoke still doesn’t show up. It renders an alpha, but no visible smoke. I also tried hitting Edit Mapping after unchecking the T, but it crashes still.

I have a feeling he’s focused on the new software coming out and bug fixes are probably on pause or something. This is obviously a large bug that makes the software pretty useless unless there is a workaround I haven’t found yet, like maybe mapping something else other than temp.

Hopefully he has the bandwidth to address it someday. I emailed the support email, so maybe they at least know about the issue.

I"ll plan to use it on the PC for the meantime.

How frustrating, bugs on PC and Mac side. I don’t think Jascha is planning on doing any further updates to tfd, but I do hope he reconsiders. Maybe if LW gets a new lease of life, he may reconsider??

Ya, hopefully so, at least to fix the big issue, maybe not dig too deep into TFD for Lightwave considering it’s fate. I don’t want him to waste a ton of time, but it’d be nice for legacy use until the dust settles with his new software.

Ya, I’ve abandoned all hope for Lightwave to get sold to someone. Trying to move forward but it’s hard when you’re constantly working and not a lot of time for exploring and learning something new. I have a feeling it’ll be C4D for me, but I’m still on Lightwave pumping out work lol.

I’m still holding out hope and still enjoying using LightWave :slight_smile: I use other things to get the work done, like Blender, Substance etc.
UE4 and LightWave work well together, so will continue until LightWave’s fate is sealed. The realtime fluid/smoke stuff in UE4 is pretty remarkable, considering it’s in a game engine :smiley: