Workaround for Redshift not supporting TFD on C4D R21 yet

Redshift versions 2.6.47 and 3.07 do not support TFD on R21 yet. The Redshift developers have confirmed that the next builds will add support.

There is a simple workaround to make versions 2.6.47 and 3.07 load TFD correctly, though:

  • Create folder “plugins” inside your C4D app folder if it doesn’t already exist.
    (Windows) C:\Program Files\Maxon Cinema 4D R21\plugins
    (MacOS) /Applications/Maxon Cinema 4D R21/plugins
  • Extract or move TurbulenceFD into this plugins folder.
    If you added a different folder for TFD to C4D’s plugin search path in Preferences, remove it from the search path. Make sure the TFD folder is not nested inside another folder. The .xdl64 files must be at plugins/TurbulenceFD_C4D_v1-0_1448/…xdl64
  • Rename the file TurbulenceFD_R20_1448.xdl64 to PleaseIgnoreThisOneRedshift.xdl64
  • Rename the file TurbulenceFD_R21_1448.xdl64 to TurbulenceFD_R20_1448.xdl64
  • Restart C4D

This works because C4D does not care about the filename and Redshift only loads the files TFD_loader_R15.cdl64 (which handles R15 through R19) or TurbulenceFD_R20_1448.xdl64 so far.


Gonna spread that news…will make some happy bunnies

Update: Added the note about the required install location.

Update: Added note about folder nesting.

1 Like

Redshift v2.6.48 with the fix for this issue has been released:

1 Like

I am running 2.6.48. But I still can only see the channels greyed out in the redshift volume material menu.
Do I still have to do the renaming procedure you describe above?


Please make sure you are using the licensed version of TFD rather than the Learning Edition. Other than that please contact Redshift support for issues with this version. Officially it should support TFD 1448 and later on R21.

The solution was that the unzipped “TurbulenceFD” folder was inside another “TurbulenceFD” folder. That was probably inside the zip archive?

I always unzipped all former versions and placed TurbulenceFD inside the plugins folder. That was never a problem the last years. But thats the solution if someone comes across the same problem.

Thanks! :slight_smile:

Unfortunately, it doesn’t work for me with redshift 3.0.12. Channels are still greyed even after renaming the plugin from “TurbulenceFD_R21_1452” to “TurbulenceFD_R20_1452”. The plugin is in: “C:\Program Files\Maxon Cinema 4D R21\plugins\TurbulenceFD_C4D_v1-0_1452”. No subfolder.

It doesn’t work even if I rename the plug and the folder with “1448” version number

windows 10
2 RTX 2080ti
cinema4d 21.115


Redshift 3.0.12 should even find TFD without the workaround described above. Please contact Redshift support to work this out.

It used to work, but today I wanted to start a new project with Redshift 3.0.13 and I cannot get it to work.
In the new nodegraph it offers a preset button where TurbulenceFD is shoing up. I can select from there “density” and “emission”. But it’s not beeing rendered.

When I switch to StandardRenderer fire and smoke is rendered as expected.

Is that a known problem or what changed?



Please contact Redshift support to resolve this issue.

Hi, I have the exact same problem - Latest TFD and C4D R21

If you are using the free Learning Edition of TFD note that it does not support any 3rd party render engines.
If you are using a licensed version of TFD, the above installation procedure will resolve this problem. Please make sure to check carefully that the TFD installation folder is not nested inside another folder after extraction.

TFD is found by Redshift (2.6.54 / 3.0.20) and Cinema R21 / R22 but in the volume material the options to add the scatter channel all options are grey.