Beta Release v0.2.0


Download Windows Installer
Installation Instructions

System Requirements

  • Windows 8.1 or later
  • GPU simulation requires an Nvidia GPU with CUDA CC 3.5 or later (see CUDA GPUs | NVIDIA Developer).
  • (optional) Cinema 4D R20 or later
  • (optional) Redshift v3.0.53 or newer.


  • [C4D] Added support for C4D R25.
  • [C4D] Added support for C4D R22.
  • [C4D] Show busy-indicator in status bar for long graph updates.
  • [C4D] Map C4D object enable switch to REA node bypass switch.
  • [C4D][UI] Report fatal startup errors to user in addition to logging them.
  • [DFG] Auto-connect new Voxelize nodes to existing Volume.
  • [Graph] Fixed incomplete node material setup in some cases.
  • [Graph] Fixed crash when quitting app during playback in some cases.
  • [Mesh] Viewport did not update right away when changing mesh file path.
  • [Rake] Build nodes in /create in parallel to reduce scene initialization times.
  • [UI] Added Help/Check for Updates.
  • [UI] Added busy-indicator in timeline.
  • [UI] Added several new icons.
  • [UI] Added new login dialog.
  • [UI] Added Examples menu.
  • [UI] Updated button styling.
  • [UI] Bring open dockable tabs to front when selecting from the Window.
  • [Viewport] Improved viewport playback speed in some cases.
  • [Viewport] Fixed error in some cases when simulating on non-display device of different architecture.
1 Like

Standalone app is crashing whenever a template/example is loaded.

Error says it’s writing a crash dump, but the folder is empty.

Could you send the log file from %USERPROFILE%\ReactionsData\reactions.log?
Thank you.

I’m not able to run this new beta. Crashes with any interaction.

Sure: (1.5 KB)

1 Like

This issue seems to affect GeForce RTX 30 series GPUs. Looking into it…

can’t seem to get the volume to show up with redshift(3.0.49). using r23.

also doesn’t seem to recognize redshift (3.0.49)

Redshift v3.0.53 or newer is required for it to work. If you have TurbulenceFD installed, it must be v1.0 1478 or newer.

alright. does it work with the Learning Edition of tfd too or is a licensed version required?

Generally it works with the TFD Learning Edition, but Redshift does not. You can however uninstall TFD entirely to use Redshift with Reactions.

This issue seems to affect GeForce RTX 30 series GPUs. Looking into it…

This matches my experience - 2x3080 cards, Windows and C4D R24 and it’s a quick crash whenever I try any Reactions.

Having issues with the Reactions plugin in both c4d S24 and R25.

  • tried to open both examples. they open and play on full open prospective view but c4d freezes when switching to 4 windows active view.
  • c4d gets very sluggish and crashes when trying to render with redshift
  • can’t seem to render in octane either
    c4d S24.111
    c4d R25.010
    redshift 3.0.56
    octane 2021.1 RC2
    RTX 2080ti Nvidia driver 471.68

RTX 3090 x2
Crashes upon loading an example scene
Windows 10 x64

Installing over the previous build yields an error asking me to update Windows and drivers. Uninstalling all and just installing the 0.2.0 build, that error is not shown. However, the failure to draw into the viewport (reported for the earlier build) remains.

Reactions is working fine for me in C4D R25 with Octane. The bridge is working fine with an Octane tag attached and I can render to LV.

One question: How do you set the path for the caches in the C4D plugin? I tried changing the Turbulence FD to a new one, but Reactions keeps going to the same path on my C: drive.

Thank you. This new program breathes a lot of new life in Turbulence FD.

Just tried a few things in the standalone app and I get instant crashes on all of them.

  • Tried loading a template (tried all of them)
  • Tried all the examples, the only ones that didn’t crash were the Procedural SDFs
  • Tried adding an emitter, immediate crash
  • I can confirm the freeze when switching to the 4-split view in C4D.
  • I was not able to reproduce the sluggish render with Reshift. Could you send a scene file and a brief description on how to reproduce the problem?
  • What exactly happens when you render in Octane? Did you add the Octane Object tag to the TFD Legacy Render Bridge object?

Thank you.

Which version was the one you installed over? I did not get that error when installing over 0.1.12.
Thank you.

Thank you for your report.
Could you please send the log file from %HOMEPATH%\ReactionsData\reactions.log?