Beta Release v0.2.1


Download Windows Installer
Installation Instructions

System Requirements

  • Windows 8.1 or later
  • GPU simulation requires an Nvidia GPU with CUDA CC 3.5 or later (see CUDA GPUs | NVIDIA Developer).
  • (optional) Cinema 4D R20 or later
  • (optional) Redshift v3.0.53 or newer.


  • [C4D] Fixed hang when using split viewport.
  • [C4D] Fixed: 3rd party renderers did not update scene correctly via Legacy Render Bridge.
  • [CrashHandler] Write crash dumps before showing error message rather than after.
  • [CrashHandler] Some threads were not handled, leading to missing messages/dumps.
  • [Graph] Fixed crash on quick interactive updates of some node configs.
  • [Installer] Upgrade installs did not work correctly.
  • [Rake] Fixed launch error, in some cases crash, on CUDA CC8.6 (RTX 30 series) with some driver versions.
  • [Volume] Fixed crash when using CPU compute in some cases.

I don’t know where is the problem: in GPU or Reactions. I never saw the simulation cloud in the viewport since version 0.2.0 (the first one I tried). I only see the particle emitter:

Tried both in Cinema 4D R24 & R25.
Running on Windows 10, GTX 1080, NVIDIA Driver v.472.12

I have loaded the sample template Explosion and it plays fine. I swap the cube for a sphere and the system breaks. I then swap back in the original cube and it stays broken. Once either the sphere or the cube is reconnected, particles live for about 16 frames and disappear, but neither show anything more than the particles. And then you go back to the start it shows the particles in the last frame before restarting (cube only, not sphere). Not sure if all the above are glitches, a bug, but it seems like odd behaviour.

Thanks Aleksei,
could you send the log file from %HOMEPATH%\ReactionsData\reactions.log?
Does the Volume show in the standalone app?

What steps exactly did you use to swap the cube for a sphere? Did you use the C4D Object Manager or Reactions Graph Editor?

The short particle lifetime (0.5sec = 15F) is set up on the Particle Emitter on the death attribute. This attribute stores the time at which the particle will die. The User Guide chapter to explain everything about the Particle Emitter is coming soon.

The particles should be voxelized to drive the volume simulation, though. If this breaks, when changing particle settings, it’s probably a bug. Please describe the changes step-by-step that lead to this behavior.

Thank you.

Hi, Jascha
Sending you the log file: (90.4 KB)

In the standalone app, at the moment when I load the flame thrower template I see the volume in the first frame (once the template objects appear in the scene):

frame 1:

But when I click “play” button, or just make one frame step forward in the timeline, the volume disappears and never appears again:

frame 2:

1 Like

Please try Build v0.2.1-8. If the render still does not show up, please send the new log file.
Thank you.

Unfortunately, the same behavior both in Cinema 4D and standalone. The updated log file: (94.7 KB)

By the way, I don’t know how to check which exact version of the Reactions I’m using. The only way I found it’s via the uninstall window:


Ok, an update here: I couldn’t install the 0.2.1-8 version. I uninstalled the 0.2.1 version, but couldn’t install the recent one. The installation process ends without any success or warning message and looks like this:

The log file does not contain any output from v0.2.1-8, only v0.2.1.

You can check which version you have installed in one of several ways:

  • Windows’ Apps & Features, search for “react…”, select the entry to show the version number
  • Start Reactions and select the Log tab. The version will show near the top as Reactions v0.2.1-8 (2021-10-12)
  • In Windows Explorer right-click the file C:\Program Files\Jawset Reactions\bin\reactions.exe and select Properties. The version is listed as “File Version” in the Details tab.

When you check the installed version in Windows Apps&Features, which one does show?
Could you please try the following:

  • Uninstall whichever Reactions version shows in Apps&Features
  • Install the previous v0.2.1 again
  • Start the v0.2.1-8 installer with logging enabled as follows:
    • From the Start Menu open Command Prompt
    • Drag&Drop the v0.2.1-8 install into the window
    • Before pressing Enter, type Space and then -l Desktop\install-0.2.1-8.log
    • Press Enter and click through the installer
  • The installer should have generated one or two log files on your Desktop
  • Please send these files.

Thank you.

Done all the steps above, sending you the log file: (2.3 KB)

1 Like

This looks like the installer file has been corrupted somehow. The installer should have displayed the error (next update will fix this), but otherwise couldn’t have resolved this issue. Please try re-downloading the installer: Build v0.2.1-8

That’s right, something wrong was with the installer: the sizes are different:


Maybe this was related to the fact that Windows recognized this app as a potential threat and didn’t want me to save it. Anyway, I successfully installed the v.0.2.1-8, but the problem remained. All behavior is exactly the same. Here is the log:

P.S. Maybe this side information will help somehow: in TurbulenceFD plugin (not Reactions) after some update (either drivers or the TFD itself, can’t say) I stopped seeing voxel grid in the container. Haven’t seen it for half a year already:

Right, if SmartScreen warns about the installer that’s an indication that it may have been corrupted.
I wasn’t able to reproduce this issue yet, so i’m flying blind a bit with the fix. Here is a new build that contains another attempt to get this behavior under control:
Build v0.2.1-20

The TFD issue is not related to this.

Unfortunately, the same issue. Is there anything else about how I can help?

Could you send the log from v0.2.1-20?
Thank you.

Here it is:

Here is today’s Build v0.2.1-26.
Could you please send the log file (not screenshot) regardless of whether it resolves this issue?
Thank you.

This version works! :slight_smile:
Here is the log file: (121.7 KB)

Some background information:
When I tried to archive the log file into zip I couldn’t, because of the error. The error message said that the file can’t be accessed because it used by another process (application). I understood that Reactions is continuing writing something to the log file and decided to close it. When I clicked close button the Reactions crashed. It was really continuing writing something to the log file. You can see it in the end of the log.

1 Like