Crashing on 6787 R21

I had to manually add the path to the plugin preferences and when i load up the explosion example scene I get a reactions object in OM and then a crash with a bug report…enclosed…i hope it i can add a txt file !!
No no way to attach !! is tguis enough ? i wil email the rest if needed
reactions.dll: jawset_reactions_construct + 0x3c2e85 (SP: 0x000000D1AEDFA150, PC: 0x00007FF9E4AD6B45)
reactions.dll: jawset_reactions_construct + 0x3f1ea4 (SP: 0x000000D1AEDFA200, PC: 0x00007FF9E4B05B64)
reactions.dll: jawset_reactions_construct + 0x3ee91e (SP: 0x000000D1AEDFA490, PC: 0x00007FF9E4B025DE)
reactions.dll: jawset_reactions_construct + 0x27331f (SP: 0x000000D1AEDFA4E0, PC: 0x00007FF9E4986FDF)
plugin_c4d_r21.xdl64: Ordinal0 + 0x144f9 (SP: 0x000000D1AEDFA640, PC: 0x00007FF9FD2F44F9)
c4dplugin.xdl64: 0x00007FFA06130D2C (SP: 0x000000D1AEDFA990, PC: 0x00007FFA06130D2C)
c4dplugin.xdl64: 0x00007FFA059A73B9 (SP: 0x000000D1AEDFA9D0, PC: 0x00007FFA059A73B9)
c4dplugin.xdl64: 0x00007FFA059973DB (SP: 0x000000D1AEDFAC20, PC: 0x00007FFA059973DB)
c4dplugin.xdl64: 0x00007FFA0662AD9C (SP: 0x000000D1AEDFB620, PC: 0x00007FFA0662AD9C)
c4dplugin.xdl64: 0x00007FFA05B77DD4 (SP: 0x000000D1AEDFBED0, PC: 0x00007FFA05B77DD4)
c4dplugin.xdl64: 0x00007FFA067561D2 (SP: 0x000000D1AEDFCBA0, PC: 0x00007FFA067561D2)
c4dplugin.xdl64: 0x00007FFA05B75AFB (SP: 0x000000D1AEDFCBF0, PC: 0x00007FFA05B75AFB)
c4dplugin.xdl64: 0x00007FFA0707E197 (SP: 0x000000D1AEDFCC70, PC: 0x00007FFA0707E197)
c4dplugin.xdl64: 0x00007FFA0707564F (SP: 0x000000D1AEDFCCD0, PC: 0x00007FFA0707564F)
Cinema 4D.exe: 0x00007FF7BA8D15D9 (SP: 0x000000D1AEDFCDB0, PC: 0x00007FF7BA8D15D9)
Cinema 4D.exe: 0x00007FF7BA8D15A3 (SP: 0x000000D1AEDFCEE0, PC: 0x00007FF7BA8D15A3)
Cinema 4D.exe: 0x00007FF7BA8D40E9 (SP: 0x000000D1AEDFCF10, PC: 0x00007FF7BA8D40E9)
Cinema 4D.exe: 0x00007FF7BA8D3C03 (SP: 0x000000D1AEDFD020, PC: 0x00007FF7BA8D3C03)
drawport.module.xdl64: 0x00007FFA22981BF2 (SP: 0x000000D1AEDFD050, PC: 0x00007FFA22981BF2)
drawport.module.xdl64: 0x00007FFA228E0760 (SP: 0x000000D1AEDFD1A0, PC: 0x00007FFA228E0760)
drawport.module.xdl64: 0x00007FFA2295913A (SP: 0x000000D1AEDFD1E0, PC: 0x00007FFA2295913A)
drawport.module.xdl64: 0x00007FFA2295CD43 (SP: 0x000000D1AEDFD280, PC: 0x00007FFA2295CD43)
drawport.module.xdl64: 0x00007FFA22964031 (SP: 0x000000D1AEDFD5A0, PC: 0x00007FFA22964031)
drawport_opengl.module.xdl64: 0x00007FFA2099D4E4 (SP: 0x000000D1AEDFD600, PC: 0x00007FFA2099D4E4)
drawport_opengl.module.xdl64: 0x00007FFA209A06DD (SP: 0x000000D1AEDFD7B0, PC: 0x00007FFA209A06DD)
c4dplugin.xdl64: 0x00007FFA0674B18C (SP: 0x000000D1AEDFD870, PC: 0x00007FFA0674B18C)
c4dplugin.xdl64: 0x00007FFA05B7E751 (SP: 0x000000D1AEDFD8C0, PC: 0x00007FFA05B7E751)
c4dplugin.xdl64: 0x00007FFA05B6B0D6 (SP: 0x000000D1AEDFD990, PC: 0x00007FFA05B6B0D6)
c4dplugin.xdl64: 0x00007FFA070A3FF1 (SP: 0x000000D1AEDFFAB0, PC: 0x00007FFA070A3FF1)
Cinema 4D.exe: 0x00007FF7BAABD7D2 (SP: 0x000000D1AEDFFB10, PC: 0x00007FF7BAABD7D2)
Cinema 4D.exe: 0x00007FF7BAABCB32 (SP: 0x000000D1AEDFFBC0, PC: 0x00007FF7BAABCB32)
Cinema 4D.exe: 0x00007FF7BAAC5CD6 (SP: 0x000000D1AEDFFC60, PC: 0x00007FF7BAAC5CD6)
ucrtbase.dll: crt_at_quick_exit + 0xaf (SP: 0x000000D1AEDFFCE0, PC: 0x00007FFA3A57FB0F)
KERNEL32.DLL: BaseThreadInitThunk + 0x14 (SP: 0x000000D1AEDFFD10, PC: 0x00007FFA3B0B7BD4)
ntdll.dll: RtlUserThreadStart + 0x21 (SP: 0x000000D1AEDFFD40, PC: 0x00007FFA3C70CE51)
rax: 0x0000000000000000 rbx: 0x0000027427030620 rcx: 0x000002747b7d0000 rdx: 0x000002747b7d0000
rdi: 0x00000274271bfe30 rsi: 0x00000274271bfea8 rbp: 0x000000d1aedfa1b0 rsp: 0x000000d1aedfa150
r8: 0x0000000000000000 r9: 0x0000000000000001 r10: 0x0000000000008000 r11: 0x000000d1aedfa050
r12: 0x0000027426cc24a0 r13: 0x0000027426cc2580 r14: 0x0000027433ffa7d0 r15: 0x0000027433ffa7d0
eflags: 0x0000000000010202 rip: 0x00007ff9e4ad6b45 cs: 0x0000000000000033 ds: 0x000000000000002b
es: 0x000000000000002b fs: 0x0000000000000053 gs: 0x000000000000002b ss: 0x000000000000002b
ContextFlags: 0x000000000010005f MxCsr: 0x0000000000009fe1 dr0: 0x0000000000000000 dr1: 0x0000000000000000
dr2: 0x0000000000000000 dr3: 0x0000000000000000 dr6: 0x0000000000000000 dr7: 0x0000000000000000
xmm0: 0x00000000000000000000000000000000 xmm1: 0x00000000000000000000000000000000 xmm2: 0x00000000000000000000000000000000 xmm3: 0x00000000000000000000000000000000
xmm4: 0x00000000000000000000000000000000 xmm5: 0x00000000000000000000000000000000 xmm6: 0xc08136fdf0bc0534bfd55553ae7032ca xmm7: 0x0000000000000000c050ab399e8447a4
xmm8: 0xc0378ba80e8e01fa4051ad7bc01366b9 xmm9: 0x00000000000000004050ab399e8447a4 xmm10: 0x4040a6325f42f534405792c47fc82760 xmm11: 0x40590000000000004059000000000000
xmm12: 0x40378ba80e8e01fb4051ad7bc01366b8 xmm13: 0x00000000000000000000000000000000 xmm14: 0x00000000000000000000000000000000 xmm15: 0x00000000000000000000000000000000

			ThreadName = unknown
		win32u.dll:	NtUserMsgWaitForMultipleObjectsEx + 0x14 (SP: 0x000000D1AB2FF288, PC: 0x00007FFA398D9A84)
		USER32.dll:	MsgWaitForMultipleObjectsEx + 0x9d (SP: 0x000000D1AB2FF290, PC: 0x00007FFA3A811D1D)
		Cinema 4D.exe:	0x00007FF7BA57AB12 (SP: 0x000000D1AB2FF2D0, PC: 0x00007FF7BA57AB12)
		Cinema 4D.exe:	0x00007FF7BA57C15E (SP: 0x000000D1AB2FF470, PC: 0x00007FF7BA57C15E)
		Cinema 4D.exe:	0x00007FF7BA575AB4 (SP: 0x000000D1AB2FF4A0, PC: 0x00007FF7BA575AB4)
		Cinema 4D.exe:	0x00007FF7BA575C94 (SP: 0x000000D1AB2FF510, PC: 0x00007FF7BA575C94)
		Cinema 4D.exe:	0x00007FF7BAB006EE (SP: 0x000000D1AB2FF760, PC: 0x00007FF7BAB006EE)
		KERNEL32.DLL:	BaseThreadInitThunk + 0x14 (SP: 0x000000D1AB2FF7A0, PC: 0x00007FFA3B0B7BD4)
		ntdll.dll:	RtlUserThreadStart + 0x21 (SP: 0x000000D1AB2FF7D0, PC: 0x00007FFA3C70CE51)

OK so i updated to the latest tfd plugin and now i get a stage further i get the render bridge object appearing then a crash. I have sent a bug report to support

I thought i would see if reactions runs…it does not it gives a Sigabrt error in reactions.dll, would you like the crash dump emailed ?

Thanks Paul, the _BugReport.txt is enough for now.

1 Like

Ok, the minidump.dmp would be useful. Please send via email or attach here.
Thank you. (16.4 KB)
Here is the reactions dump

This is the last dump that the Reactions standalone produced on your system. The original crash was from within C4D. The dmp for that crash is in %APPDATA%\Maxon\Maxon Cinema 4D R21_…_bugreports\minidump.dmp
Please make sure that the dump is from the crash you reported by reproducing the crash first. Otherwise it might have been from another crash that has happened in the meantime.

Could you also try the new build 6788?

Thank you.

OK will have a check on this soon and give any dumps if they occur

Both c4d r21 and Reactions are crashing dumps (259.6 KB)

OK some progress. I tried updating my drivers, as you recall you suggested using studio drivers before, and was getting real annoying looping driver problems when I updated to a studio driver for the TitanX so I went back and just updated the 1070 card with it’s correct game ready drivers which were also compatible with the titan now both Reactions stand-alone and in C4D open fine with no crashes…thing is I do not have a clue how to use Reactions inside cinema 4D !!

I briefly got an option to choose primary compute device in reactions but now that has gone and I have no PCD or options. Edit…it comes an goes

Could you try build 6790 and check for the crash again?
It should resolve the crash in C4D caught by the minidump.
There might be others, thus if it crashes again, please send the new minidump.

Thank you.

Do you mean the Preferences pane disappeared, the dropdown box in it or no GPU was selectable there?

OK will play tonight and let you know hoe things go. The pref pane was there but sometimes it could show the options and sometimes not

OK downloaded the latest build. Reactions starts with no windows showing then after a pause they come and then go again. I can select, for a short while, the menus to such places as the graph editor. In Cinema 4D i open the explosion preset and I get all the objects in OM but that is it…they do nothing. no objects in the viewport and nothing happens on play. I have updated to the latest Nvidia drivers.

Reactions sees both my GPU’s and CPU Cinema 4D sees none…

build 6790

Thanks Paul. This is pretty messy indeed. Could you attach the log file %USERPROFILE%\ReactionsData\reactions.log?

OK trying with the latest build and still no joy. The option to choose the primary compute device does come up in the main reactions window after about 30 secs. I am using reactions v 6796 with the latest Redshift demo installed…2 cards a 1070 and a Titan X latest drivers. (3.7 KB)