Stand-alone viewport

We have installed the latest beta stand-alone of Reactions and loaded the example flame thrower and explosion and all we can see in our viewport are the particles. There are no volumes being displayed. Is there a setting somewhere to view the volumes that we need to enable? When we enable the boxes in the volume grid we can see the sparse volume cubes forming around the particles but no actual volume data is displayed. We are running 3090x2 on windows 10. Please advise:)

Volumes should show in the viewport without changing any settings first.
Please provide the log file from %HOMEPATH%\ReactionsData\reactions.log. It holds additional information that may help to narrow down the issue.
Thank you.

I seem to have the exact same situation as Aleksei. The volume shows in the viewport upon loading the flamethrower example, but as soon as time is advanced in any way, it dissappears and does not come back. Here is the log file:

reactions.txt (6.4 KB)

Also tried changing Default Cache path in preferences and the result is the same. Also tried Caching to a different drive, still the same. Hopefully you can find some info in the log. Thank you!

Reactions is definitely calculating volumes, as i am able to export VDB caches and load them into Octane just fine. Just not seeing anything in the viewport within Standalone…

It would be nice to see a progress bar when exporting VDB sequences:)

Since we cannot see our volumes in the standalone yet, we are working on exporting VDB files out using the “explosion” template. When exporting all VDB files, we have hit a problem. When we export the sequence at a Voxel Size of .2 (as it comes in with the template), we get the full animation of 240 frames. When we decrease the Voxel Size to .1 however, the animation only gets to frame 16, then it holds that frame for the remainder of the output without progressing. We tried running the timeline through multiple times and watching the timestamps progress so we know it did indeed output all the files. Here is the log file associated with that problem:

reactions.txt (3.3 MB)

Indeed, please try Build v0.2.1-8. If the problem persists, please send the new log file.
Thank you.

Absolutely. It’s planned but not yet scheduled for a specific update. You can see a simplistic progress during export in the Log tab.

If you frequently switch to other apps to use the VDBs, you can also check Cache As VDB on the Volume Grid. It will then always write the VDBs while simulating, making the extra export step unnecessary.
Note that caching to VDB is slower though. If you iterate on the sim settings in Reactions for a while, it may be preferable to not cache to VDB and export explicitly instead.

We uninstalled the previous version and installed Build v02.1-8 and still have the same issue with volumes disappearing after first frame. Is it a problem with the 3090 cards? We also have some A5000 cards we could try it on, although they share a lot in common with the 3090… Here is the new log file:

reactions.txt (57.8 KB)

What is the plan for importing animation into the standalone Reactions for emitters and collisions? Alembic?

The problem is that the Volume viewport render module is not selecting the GPU correctly. I wasn’t able to reproduce this issue yet, so i’m flying blind a bit with the fix. Here is a new build that contains another attempt to get this behavior under control:
Build v0.2.1-20

Yes. You can import Alembic files using the Meshes/Poly Mesh node. A simple use of this node can be found in Examples/Volumes/Collision Object.

Hey Jascha- We updated to Build v0.2.1-20 and initially we had the same problem. However, we went into preferences and switched our “Primary Compute Device” to our second NVidia 3090 and it seems to be drawing in the viewport correctly and consistantly now! Yay! For the record, our first card in the list within Reactions Preferences is listed as “GPU 0:NVIDIA RTX 3090,CC8.6, PCI bus 33”. Our second card is listed as “… PCI bus 75”. Not sure if there is anything useful about that info but figured we would pass it along if it may help you help someone else with problems connecting to their cards:) Thank you!

Ok, that’s something. It’s slightly slower to use a GPU for sim that is not also driving the display (data has to be sent to the display GPU then). OTOH the display GPU has less memory available for sim, s.t. you can push the grid size higher when using a non-display GPU.

Here is today’s Build v0.2.1-26.
Could you please send the log file regardless of whether it resolves this issue?
Thank you.

Hey Jascha

I am using 0.2.1, Windows 10, Intel 5820k, Nvidia 750 Ti, The App doesn’t shut down and I have to kill it from task manager every single time.

Btw, I am loving it, it seems really great.

1 Like

Could please you try the latest nightly Build v0.2.1-27 and send the log file %HOMEPATH%\ReactionsData\reactions.log after shutting down and killing the app?
Thank you.

Yes, sure, I ll download and install it and I ll send the log.

Btw, thanks for the quick reply. :grinning: :handshake: